通达信顶底先知指标股票主力动向

  来源:  

REFLINE:0;
顶底:=EMA(CLOSE,3)-EMA(CLOSE,8);
先知:=EMA(顶底,5);
主力动向:= 2*(顶底-先知);
tdx1:=EMA(顶底,5)*5;
tdx2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5;
tdx3:IF(tdx2>0,tdx2,0),POINTDOT,COLORRED;
tdx4:IF(tdx2<0,tdx2,0),POINTDOT,COLORGREEN;
STICKLINE(tdx2>0,0,tdx2,2.8,0),COLORRED;
STICKLINE(tdx2>0,0,tdx2,2.8,0),COLOR000088;
STICKLINE(tdx2>0,0,tdx2,2.6,0),COLOR000099;
STICKLINE(tdx2>0,0,tdx2,2.4,0),COLOR0000AA;
STICKLINE(tdx2>0,0,tdx2,2.2,0),COLOR0000BB;
STICKLINE(tdx2>0,0,tdx2,2,0),COLOR0000CC;
STICKLINE(tdx2>0,0,tdx2,1.8,0),COLOR0000DD;
STICKLINE(tdx2>0,0,tdx2,1.5,0),COLOR0000EE;
STICKLINE(tdx2>0,0,tdx2,1.0,0),COLOR0000FF;
STICKLINE(tdx2>0,0,tdx2,0.0,0),COLOR0000FF;
STICKLINE(tdx2<0,0,tdx2,2.8,0),COLORGREEN;
STICKLINE(tdx2<0,0,tdx2,2.8,0),COLOR007700;
STICKLINE(tdx2<0,0,tdx2,2.6,0),COLOR008800;
STICKLINE(tdx2<0,0,tdx2,2.6,0),COLOR009900;
STICKLINE(tdx2<0,0,tdx2,2.4,0),COLOR00BB00;
STICKLINE(tdx2<0,0,tdx2,2.0,0),COLOR00CC00;
STICKLINE(tdx2<0,0,tdx2,1.8,0),COLOR00DD00;
STICKLINE(tdx2<0,0,tdx2,1.5,0),COLOR00EE00;
STICKLINE(tdx2<0,0,tdx2,1,0),COLOR00FF00;
STICKLINE(tdx2<0,0,tdx2,0,0),,COLOR00FF00;
aa1:tdx2,COLORYELLOW,LINETHICK2;
aa2:tdx1,COLORFFFF00,LINETHICK2;
DRAWICON((CROSS(aa1,aa2) AND aa2<-0.25),aa2,1);
DRAWICON((CROSS(aa2,aa1) AND aa1>0.25),aa1,2);

通达信顶底先知指标股票主力动向.jpg