当前位置首页 > 通达信指标公式

通达信精准主图买卖指标公式

  来源:  

通达信主图:=MA(C,1);
通达信公式:=SMA(SMA(SMA(通达信主图,2,1),2,1),2,1);
SMsa:=MA(通达信公式,3);
精准主图买卖:IF(LLV(MA(通达信公式,8),3)<通达信公式,LLV(MA(通达信公式,8),3),通达信公式);
IF(通达信公式>SMsa,通达信公式,DRAWNULL),COLORRED,LINETHICK4;
IF(通达信公式<SMsa,通达信公式,DRAWNULL),COLORGREEN,LINETHICK4;
SNAKEA:HHV(MA(通达信公式,1),13),COLORYELLOW;
ggdd1A:=(2*CLOSE+HIGH+LOW)/4;
ggdd2A:=MA(ggdd1A,7);
ggdd3A:=ggdd2A-MA(ggdd1A,7/2)<0;
ggdd4A:=ggdd2A-MA(ggdd1A,7/2)>0;
ggdd5A:=BARSLAST(ggdd3A);
ggdd6A:=0-BARSLAST(ggdd4A);
ggdd7A:=IF(ggdd3A<=0,ggdd5A,ggdd6A);
STICKLINE(SNAKEA>通达信公式 AND 通达信公式>SMsa,SNAKEA,通达信公式,0,0),COLORBLUE;
STICKLINE(SNAKEA>SMsa AND 通达信公式<SMsa,SNAKEA,SMsa,0,0),COLORBLUE;
ggdd11A:=(CLOSE*2+HIGH+LOW)/4;
ggdd21A:=EMA(ggdd11A,13)-EMA(ggdd11A,34);
ggdd31A:=EMA(ggdd21A,5);
ggdd2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
ggdd3:=((REF(ggdd2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggdd4:=((REF(ggdd3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggdd5:=((REF(ggdd4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggdd6:=((REF(ggdd5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggdd7:=((REF(ggdd6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggdd8:=((REF(ggdd7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggdd9:=((REF(ggdd8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggddA:=((REF(ggdd9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggddB:=((REF(ggddA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggddC:=((REF(ggddB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggddD:=((REF(ggddC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggddE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
ggddF:=((REF(ggddE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggdd10:=((REF(ggddF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggdd11:=((REF(ggdd10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggdd12:=((REF(ggdd11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggdd13:=((REF(ggdd12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggdd14:=((REF(ggdd13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggdd15:=((REF(ggdd14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggdd16:=((REF(ggdd15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggdd17:=((REF(ggdd16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggdd18:=((REF(ggdd17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
ggdd19:=((REF(ggdd18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
ggdd1B:=(REF((((((((((((ggddE OR ggddF) OR ggdd10) OR ggdd11) OR ggdd12) OR ggdd13) OR ggdd14) OR ggdd15) OR ggdd16) OR ggdd17) OR ggdd18) OR ggdd19),1) AND ggdd2);
STICKLINE(ggdd1B,O,O+(C-O)/3,2,0),COLOR10FFFF;
STICKLINE(ggdd1B,O,O+(C-O)/3,1,0),COLOR00FFFF;
AA:=(REF((((((((((((ggdd2 OR ggdd3) OR ggdd4) OR ggdd5) OR ggdd6) OR ggdd7) OR ggdd8) OR ggdd9) OR ggddA) OR ggddB) OR ggddC) OR ggddD),1) AND ggddE);
STICKLINE(AA,O,O+(C-O)/3,2,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;
as3:=EMA(CLOSE,55);
as4:=MA(CLOSE,75);
as5:=EMA(as4,3);
as6:=EMA(as5,3);
as7:=(HIGH + LOW) / 5;
as8:=(MA(as7,4)) - (MA(as7,34));
as9:=CROSS(as8,0);
sa0:=CROSS(0,as8);
sa1:=BARSLAST(as9);
sa2:=BARSLAST(sa0);
sew:=REF(as9,1);
sa4:=REF(sa0,1);
sa5:=BARSLAST(sew);
sa6:=BARSLAST(sa4);
sa7:=IF((sa5 < sa6),(REF((HHV(HIGH,2)),sa5)),(REF((LLV(LOW,2)),sa6)));
sa8:=(((REF(CLOSE,1)) <= (REF(sa7,1))) AND (CLOSE > sa7)) AND (sa1 < sa2);
sa9:=(((REF(CLOSE,1)) >= (REF(sa7,1))) AND (CLOSE < sa7)) AND (sa2 < sa1);
ew0:=sa8 AND ((COUNT(sa8,sa1)) = 1);
ew1:=sa9 AND ((COUNT(sa9,sa2)) = 1);
ew2:=ew0 AND ((REF(BARSLAST(ew1),1)) < (REF(BARSLAST(ew0),1)));
ew3:=ew1 AND ((REF(BARSLAST(ew1),1)) > (REF(BARSLAST(ew0),1)));
DRAWTEXT(ew2,SMsa*0.99,'←═≒∝'),COLORYELLOW;
ew2:=AMOUNT/(VOL);
YY:=MA(ew2,13);
ew1:=(C-YY)/YY*100;
MIDC := MA(CLOSE,22);
UPPERC:= MIDC + 2*STD(C,22);
LOWERC:= MIDC - 2*STD(C,22);
sa1:=(C-LOWERC)/(UPPERC-LOWERC);
sa2:=FORCAST(sa1,3);
LIFENGCYC:=(REF(ew1,1)<-15 AND REF(sa1,1)<0 AND ew1>REF(ew1,1));
STICKLINE(LIFENGCYC>0,C,O,2,0),COLOR10ABFF;
DRAWTEXT(LIFENGCYC>0,LOW*0.99,'☆'),COLORDD00DD;

通达信精准主图买卖指标公式.jpg

热门搜索